Software installation

Almeza MultiSet => Unattended software installation => : lleal September 30, 2009, 06:57:27 PM



: Hidden window during auto installation
: lleal September 30, 2009, 06:57:27 PM
I'm trying to automate the installation of a Mitsubishi's MX Component package.
 
At one point during the installation I have to click [OK] on a warning screen:

There is a possibility for improper installation if you execute without closing all the running applications
 
However, when I run the installation list from the MultiSet player, and it reaches this point the window remains hidden under a big blue setup/background screen and the auto installation stops. The MultiSet log shows ???Searching for necessary windows???
I have to use [Alt] + [Tab] in order to get to the install window and continue the installation.
 
This was not the case when I recorded the install list, is there a way around this issue?


: Re: Hidden window during auto installation
: Alex September 30, 2009, 07:22:51 PM
Ok. Please type full name of application and version. And if you may type the download link.
We will download, test them and send report to you.


: Re: Hidden window during auto installation
: lleal September 30, 2009, 08:03:18 PM
MX Component Version 3.11M (SW3D5C-ACT-E)

for a brief info on it you can go here:
http://www.mitsubishi-automation.com/products/software_mx_components_content.htm (http://www.mitsubishi-automation.com/products/software_mx_components_content.htm)

However, there is no download link for it, its a part of a larger software package.
I have screen shots, but don't see way to attach them.


: Re: Hidden window during auto installation
: Alex October 01, 2009, 09:11:18 AM
Please send your installation file on e-mail developers
  • almeza.com. Because I did not download software from link below.


: Re: Hidden window during auto installation
: lleal October 01, 2009, 11:30:34 PM
I uploaded it to Box.net (its ~50MB) and emailed you the link. Thanks


: Re: Hidden window during auto installation
: Alex October 02, 2009, 10:07:04 AM
Thank you! I received your e-mail. Now I download this software.


: Re: Hidden window during auto installation
: Alex October 02, 2009, 07:26:36 PM
Yes. Problem. We will try to resolve this problem. I will write the solution in this topic.


: Re: Hidden window during auto installation
: Alex October 02, 2009, 09:33:42 PM
Solution:

1. Open package's properties. Tab 'Script'.
2. Find problem action (in my script this action number 14 Left mouse button pressed  OK [Button]).
3. Select this action in the list and press 'By time' button.
4. Press 'OK' button on the dialog.

Run package.


: Re: Hidden window during auto installation
: lleal October 03, 2009, 12:41:19 AM
Thanks,

It worked, but I had to switch to "By time" not only the 'button pressed', but also the 'button release' action:

By time  -->  24 Left-mouse button pressed  OK [Button]
By time  -->  25 Left-mouse button released  OK [Button]


: Re: Hidden window during auto installation
: Alex October 03, 2009, 09:26:58 AM
OK. Good luck!


Sorry, the copyright must be in the template.
Please notify this forum's administrator that this site is missing the copyright message for SMF so they can rectify the situation. Display of copyright is a legal requirement. For more information on this please visit the Simple Machines website.